Debian, instalando Paquetes Utiles

Bueno, intentaremos dejar nuestro Debian 100% usable.

Vamos a instalar plugin para el navegador, codec de Video/Audio, programas, multimedia/grabación y Oficina.

Todo esto ya se pueden hacer con Automatix2, pero amí personalmente me gusta instalar estas cosas a mano. Si se fijan al final de la Guia deje lo que yo instalo en un solo codigo, capas que les interesa la lista con programas y dejan a Debian Full

1-Agregando repositorios
Lo primero que vamos hacer es agregar los repositorio Non-Free y Multimedia. Para eso editamos nuestra Sources.list con los siguientes comandos en consola como Root (si usas KDE cambia gedit por kate):
gedit /etc/apt/sources.list
Al final del archivo agregan estas linea:
deb http://http.us.debian.org/debian/ etch main contrib non-free
deb http://www.debian-multimedia.org/ etch main
#Audacious
deb http://static.audacious-media-player.org/debian etch main
deb-src http://static.audacious-media-player.org/debian etch main

Cerramos y Guardamos los cambios. Validamos el repositorio Multimedia con el siguiente comando:
gpg --keyserver hkp://wwwkeys.eu.pgp.net --recv-keys 07DC563D1F41B907
gpg --armor --export 07DC563D1F41B907 | apt-key add -
Actualizamos los repositorios:
apt-get update

2-Instalar Java
apt-get install sun-java5-jre sun-java5-fonts sun-java5-plugin

3-Instalar Flash 9
apt-get install flashplugin-nonfree

5-Soporte para descomprimir archivos
apt-get install ark zip unzip bzip2 rar unrar

6-Reproductores de Video
Acá ya entra el gusto personal, tenemos varios para elegir. Yo personalmente uso Xine-ui. Se recomienda instalar dos Reproductores que podrín ser Xine-ui y Mplayer
Gui de Xine
apt-get install xine-ui
Gui de Xine para Gnome
apt-get install gxine
Mplayer con Gui Blue(Recomendable instalar)
apt-get install mplayer-skin-blue
Kaffeine con motor Xine
apt-get install kaffeine

7-Reproductores de Audio
Amarok con Motor Xine
apt-get install amarok amarok-xine
XMMS
apt-get install xmms xmms-mp4 xmms-musepack
Audacious (Recomendado)
apt-get install audacious audacious-plugins-extra

8-Oficina, Editores de Texto y Herramientas de trabajo
Open Office Suite
openoffice.org
Koffice Suite
apt-get install koffice
Abiword, Liviano y funcional procesador de texto
apt-get install abiword abiword-plugins

9-Imagen, Editores y Visualizadores
GIMP, Editor de Imagenes
apt-get install gimp
Gwenview, Visualizador de imagenes
apt-get install gwenview gwenview-i18n

10-P2P, programas de intercambio
Amule, Clon de Emule
apt-get install amule
Ktorrent- Cliente Bittorrent
apt-get install ktorrent

11-Programas Varios
K3B Grabación de Cd/DVD
apt-get install k3b k3b-i18n
Avidemux, editor de Video
apt-get install avidemux
AMSN, Clon de MSN
apt-get install amsn
Firestarter, Excelente cortafuegos
apt-get install firestarter
Firefox en Español
apt-get install mozilla-firefox-locale-es-ar

Listo, seguro me falta algo que lo agregare al darme cuenta.

Acá dejo en un solo paso todo lo que instalo yo.
apt-get install sun-java5-jre sun-java5-fonts sun-java5-plugin avifile-win32-plugin libdvdcss2 w32codecs flac ffmpeg vorbis-tools lame transcode ark zip unzip bzip2 rar unrar xine-ui mplayer-skin-blue audacious audacious-plugins-extra openoffice.org gimp gwenview gwenview-i18n amule ktorrent k3b k3b-i18n avidemux amsn firestarter flashplugin-nonfree mozilla-firefox-locale-es-ar

Cualquier fallo que alla se agradeceria que lo notifiquen, así ayudan a la comunidad.
La guia esta basada en la de Debian Total, visiten ese Blog que tiene cosas muy interesantes sobre esta distro.

Anuncios

29 comentarios el “Debian, instalando Paquetes Utiles

  1. una question, no hay otra manera de ingresar las llaves publicas, ya q al ejecutar las q dejaste me aparecen q no son validas esto me aparece:
    #gpg –keyserver pgp-mit.edu –recv-keys 1F41B907
    gpg: requesting key 1F41B907 from hkp server pgp-mit.edu
    ?: pgp-mit.edu: Host not found
    gpgkeys: HTTP fetch error 7: couldn’t connect: No such file or directory
    gpg: no valid OpenPGP data found.
    gpg: Total number processed: 0

    #gpg –armor –export 1F41B907 > marillat.asc
    gpg: WARNING: nothing exported

    #apt-key add marillat.asc
    gpg: no valid OpenPGP data found.

    sabs porq sale ese error, toy usando etch.

  2. Hola, me fije y tenes razon parece que cambiaron el sistema de la Key ahí lo actualize y me funciono a la perfección, fijate si ahora te anda.
    Desde ya muchas gracias por avisar.

    EDIT

    A el error era por el repositorio Multimedia que no te estava tomando la Key, agrega la que puse ahora.

  3. chevere, ahora si funciono lo de las keys, pero tengo una pregunta, derrepente muy tonta, pero en q parte puedo ubicar el avidemux, porq lo he buscado por toda parte y no lo veo. gracias

  4. El avidemux se encuentra en el repositorio multimedia que esta arríba, tendría que aparecerte.
    Larga un apt-get update por ahí no actualizastes la lista de repositorios

  5. saludos de nuevo, te cuento q lo acabo de hacer por si las moscas, pero mi duda es q cuando le doy en el menu, multimedia, no lo veo, a diferencia q si aparece el amarok el mplayer, pero cuando lo ejecuto desde konsola si arranca el programa normal. Esta era mi duda, ¿como puedo hacerlo aparecer en la parte de multimedia del menu, como aparece el amarok y el mplayer?, ha tambien no encuentro el firestarter por ningun lado, ni desde konsola lo puedo ejecutar, ese iba a ser el sgte post q te iba a dejar, jeje, hasta luego pues.

  6. aaaaaa, pense que me decias que no lo podías instalar.
    No mira, al avidemux lo encontras en:
    Aplicaciones-Debian-apps-graphics

    Es un error que tiene, que algunas aplicaciones no son bien tomadas en el menu por gnome.
    Lo que hice yo para solucionar esto fue agregar un cajon a la barra y voy poniendo ahí todas las aplicaciones que no me aparecen en el menu

    El firestarter si o si lo tenes que ejecutar como root. Amí me paso lo mismo pero una ves que lo ejecute como root me aparecio en:
    Aplicaciones-Herramientas del Sistema

  7. por cierto me olvide decirte q no uso gnome, sino kde en etch, pero gracias por el dato, ahora tratare de ejecutar el firestarter hasta luego, y sigue con estos tutos q ayudan mucho.

  8. Si usas KDE edita el menu, y habilita una opcion que se llama objetos perdidos y luego en el menu te van aparecer todos los programas que no fueron puestos en las categorias

  9. gracias estos tuto son muy utilises para los nuevos usuarios yo estoy empezando en linux y empeze por utilizar debian etch con interfaz grafica kde.
    estoy intentanto instalar una impresora epson epl-6200L cuando la mando a imprimir no imprime nada y muestra el mensaje de impresion completada que sabes tu respecto a este problema por tu ayuda mil gracias!

  10. saludos, disculpa si este no es el post para este caso pero keria preguntarte algo, al usa el mplayer y abrir un video de extension .MOV (bueno solo tengo videos de este tipo por eso no probe con otros), me sale el siguiente error: Error opening/initializing the selected video_out (-vo) device. y no puedo ver el video pero si escuchar el audio de el, gracias de antemano hasta luego.

  11. Mira no recuerdo bien pero me sucedio algo similar, lo que tenes que hacer es configurar mplayer mas exactamente en la sección Video y utiliza OpenGL, juga con esos render que uno te tiene que andar. Si yo no pongo OpenGL no puedo ver nada.
    Comentame si pudistes de lo contrario vemos como podemos solucionarlo, pero es un error comun y facil de arreglar

  12. Hola.
    Saludos, Oyes nada mas para decir que el
    gpg –keyserver hkp://wwwkeys.eu.pgp.net –recv-keys 07DC563D1F41B907
    marcaba error si les pasa lo mismo prueben con este servidor: pgp.rediris.es entonces quedaria.
    gpg –keyserver pgp.rediris.es –recv-keys 07DC563D1F41B907
    Bueno eso estodo si saludos y espero haber sido de ayuda para algunos :d

  13. No te sabría decir, yo a java lo instalo desde repositorios pero uso 32 bits, es uno de los motivos por lo cual no baje el 64 bits.
    Mira busque en mi Blog de soporte y encontre esto:
    Debian Total
    Visita ese blog es muy bueno y dejale un comentario al autor de agradecimiento

  14. Yo soy muy novato pero con esta guia deje el debian como yo lo queria al que creo este post le agradezco mucho toda esta informacion de verdad gracias :=)

  15. Gracias a vos por dejar tu mensaje.
    Era la idea del post, hacerle más fácil la puesta a punto de Debian así demostramos que Debian es tan fácil como las otras distro.

  16. hola mi nombre es alvaro y soy muy novato en linux tendo el kubuntu el problema es que no se como istalar nada estoy perdido jaja quiero instalarle los codecs para usar mp3 y demas pewro no estan como para marcarlos y tambien el flash y firefox pero cuando hago esos pasos q tienes ahi no me sirven primero en la consola me da un error es este:
    X Error: BadDevice, invalid or uninitialized input device 168
    Major opcode: 146
    Minor opcode: 3
    Resource id: 0x0
    Failed to open device
    X Error: BadDevice, invalid or uninitialized input device 168
    Major opcode: 146
    Minor opcode: 3
    Resource id: 0x0
    Failed to open device
    ScimInputContextPlugin()
    QObject::connect: No such signal KListView::doubleclicked(QListViewItem*)
    QObject::connect: (sender name: ‘unnamed’)
    QObject::connect: (receiver name: ‘KateSaveModifiedDialog’) ok luego entro en kate y pongo lo q dices ahi al final y no me deja ni guardarlo me dice q si estoy seguro tener permiso para eso o si tengo espacio en mi disco duro. q hago ayuda porfavor. me puedes escribir a mi correo theclow90 hotmail.com no se como se pone el aroba 😄 gracias.

  17. Hola como andas. Mira esta guia es para debian, por ahi los nombres de los paquetes pueden ser igual pero los repositorios no.
    Decime que version de Kubuntu usas y te digo que haces.

  18. Hola!!! he leído tus comentarios y me ha servido bastante, pero, mi mayor problema continua, se trata de que puedo ver los vídeos de youtobe más no los puedo oír, aunque puedo escuchar música.
    te agradecería cualquier ayuda

  19. Por lo que lei estas usando Mplayer para ver videos. Si es así abri el programa boton derecho sobre el anda a preferencias, en la solapa Video selecciona como driver X11 )OpenGl) si tenes una ati y si tenes una nvidia selecciona X11/Xv.
    Con el tema de youtube fijate si tenes instalado el plugin de flash en firefox o el navegador que uses, y tambien instala el plugin para el reproductor que uses en el navegador

  20. Buena gui te felicito y te agradezco… espero esto te anime a serguir adelante ayudando a todos los que nos introducimos en el tema GRACIAS

  21. Enhorabuena por tu blog! Me acabo de hacer linuxero, No hay muchas páginas que se expliquen tan claramente como ésta, sobre todo si tienes un equipo al que no le “cabe” la última distribución de linux, y tienes que apañártelas para buscar programas que sirvan para lo que uno quiere. Con tu ayuda mi toshiba Satellite 4090Xcdt (400Mz, 96Mb Ram, linux debian Ecth con Xcfe4) no tiene nada que envidiar a mi “moderno” equipo de sobremesa (1600Mz, 500Mb Ram, Xp Sp2). Saludos y gracias…

  22. Hola
    llegué a este excelente lugar, buscando en Google instrucciones para instalar Samba, de momento solo eso. Sin Linux conectado a internet.O sea bajando el paquete (Cual?) via W2. Tengo Xubuntu crees que estas instrucciones que me parecen tan claras funcionaran en esta distro?Huelga decir que soy novicio.Saludos

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s