Configurar Sonido en Debian Etch, AlsaConf AlsaMixer

Uno de los problemas que se nos suele presentar a la hora de instalar Debian es el sonido.
Amí me paso con mi placa de sonido, si bien la reconocia no estava funcionando, por suerte esto es fácil de solucionar, solo es necesario ejecutar un comando y seguir el asistente que nos aparecera.

Esta Guía esta desarrollada con:

  • Debian Etch
  • AlsaConf
  • AlsaMixer
  • Mother Asus a8n-Vm con Sonido integrado (High Definition Audio, ADI AD1986A 5.1channel CODEC)
  • Y una Consola 🙂


NOTA 1: Para realizar esta guia necesitamos tener instalado ALSA, si no es así instalalo desde consola como root con el siguiente comando:
apt-get install alsa-base alsa-utils alsa-tools
NOTA 2: Con la Tecla “Tab” nos podemos desplazar dentro de los Menus de Alsaconf

ALSACONF

1- Abrimos una consola y nos logueamos como Root. Tipeamos el siguiente comando y nos aparece una pantalla similar a esta:
alsaconf
alsaconf.png
Damos “Aceptar”

2- En esta pantalla nos aparecera el modulo de nuestra placa de sonido, en mi caso es hda-intel. Lo seleccionamos y nos vamos a “Aceptar” con la Tecla “Tab”.
alsaconf1.png

3- Nos aparece una ventana que nos pregunta si queremos configurar el modulo, le damos que “Si”.
alsaconf2.png

Listo ya tendríamos cargado el modulo correspondiente a nuestra placa. Si por alguna razon no escuchamos nada puede ser que los volumenes esten bajos, para esto necesitamos configurar alsamixer.

ALSAMIXER

1- Abrimos consola y nos logueamos como root. Tipeamos el siguiente comando:
alsamixer
Nos mostrara una ventana como esta:
alsamixer.png
En esta pantalla debemos subir los volumenes necesarios. Si no sabes cual subir, sube uno por uno y listo. Para salir basta con apretar “ESC”.
NOTA: Si el sonido se escucha mal solo tienes que jugar con los volumenes hasta que obtengas un sonido bueno. Por ejemplo si yo subo el Volumen de mono se escucha verdaderamente mal.

Anuncios

15 comentarios el “Configurar Sonido en Debian Etch, AlsaConf AlsaMixer

  1. Tengo un problema con el sonido. Alsaconf me reconoce la tarjeta de sonido, pero sin embargo, no aparecen los dispositivos de sonido como /dev/dsp, /dev/mixer, /dev/audio… y algunos más que son necesarios para el sonido según tengo entendido.
    cuando intento arrancar un mezclador (alsamixer) me dice que no encuntra dispositivos mezcladores, pero sin embargo, la tarjeta de sonido la ha configurado sin ningun problema. ¿Esto devido a que es?

  2. Tenrías que fijarte que placa tienes y en la página de alsa ver que modulo usa. Amí me paso eso con Ubuntu Dapper que me reconocia la placa pero no andava, hasta el modulo me lo tomava. Simplemente era que la version de alsa que traía no era compatible con mi placa de sonido.

  3. Hola, mucho gusto. Tengo un problema con debian y el sonido (integrado de NVIDIA). Cuando me logueo en modo gráfico, y carga el escritorio los parlantes comienzan a hacer un chillido finito, sale sonido, pero el chillido es más fuerte, y cuando intento configurar alguna opción del mixer, se queda mudo y tengo que reiniciar la PC. Así constantemente, probé varias configuraciones. La placa es una ASUS m2npv-vm, tendrías alguna idea de qué puede ser?

  4. Tu placa y la mía son muy parecidas. Sabes que lo que vos me decis me paso con Madriva 2006 y Suse 10, y llegue a una conclusión, era la version de del kernel y alsa que traía.
    Que distro usas? y que version?

  5. Hola, uso Debian Etch que trae el kernel 2.6.18, la versión de alsa ni me la se, pero es actual. Lo que me estaba fijando es que yo tenía otra instalación de debian en otra partición que ese problema no me lo hacía (tenía otros problemas, me parece que el sonido salía directo porque no funcionaba el mixer), entonces quise ver como estaba configurado y cuando ingresé hizo el mismo problema. Espero que no sea un problema de hardware. Gracias.

  6. Me fije y como te dije tu placa es igual a la mia, y tiene el mismo sonido. Tambien uso Debian Etch con el kernel por defecto y me anda bien. Cuando tirastes el alsaconf elegistes el modulo Intel? En alsamixer tenes mono desactivado? Acá te dejo mi configuracion del Mixer

  7. Gracias, me voy a fijar. Cuando corrí alsaconf, dejé que eligiera el driver automáticamente, de hecho no me preguntó nada. Voy a ver lo del módulo, muchas gracias, Despues te cuento.

  8. Otra cosita que te puede servir.
    Anda a Escritorio-Preferencias-Selector de Sistema Multimedia.
    En la ventana que se abre seleciona en el apartado salida ALSA, y si no anda, proba con OSS.
    Suerte. Si solucionas tu problema te agradeceria que dejes tu comentario asi le sirve a otra persona.

  9. De nuevo yo, me fijé y el módulo que instala es el hda-intel. En realidad tengo kde, y en el Centro de Control-Sonidos y Multimedia-Sistema de Sonido ya había probado configurar ALSA y OSS, con OSS hace un chillido pero diferente. Si encuentro la solución voy a dejar el comentario. Saludos y muchas gracias.

  10. pablo, tengo la misma placa y el mismo problema, lo pude solucionar siguiendo lo siguiente:
    Cause & Solution:
    – The problem affects some linux distros (opensuse, ubuntu)
    – the solution: set “options snd-hda-intel position_fix=1 model=3stack” to “/etc/modprobe.d/alsa-base” or “/etc/modprobe.d/sound” in opensuse.

    colocar esta linea “options snd-hda-intel position_fix=1 model=3stack” en “/etc/modprobe.d/alsa-base” tambien en /etc/modprobe.conf.local y en /etc/modprobe.conf
    luego se esto nunca mas hizo el chillido
    saludos

  11. hola.
    Bueno, tengo instalado alsa, pero o no entiendo bien como se hace o no funciona.
    abro la terminal y tecleo asi tal cual alsaconf? si es asi no hace nada, dice comand not found, y si tecleo alsamixer dice: “alsamixer: function snd_ctl_open failed for default: No such file or directory”
    Gracias

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s